Chapter 2. Installation

Installation and requirements details for J4Schema extension

Requirements

J4Schema is tested on Joomla! 1.5.26 and 2.5; however it should work on Joomla! 1.7, too. Anyway, we strongly suggest you to always use the latest Joomla! version, since it patches all the known bugs.

[Warning]J4Schema and Joomla 1.5

In order to use J4Schema under Joomla 1.5 you must install the latest available version (at this time is 1.5.26) and enable the Mootools upgrade system plugin.

J4Schema needs Mootools 1.2+, without it you wouldn't be able to load attributes and types trees.

System requirements are less restrictive than Joomla!, so, if you can run the CMS without problems, you shouldn't have any problems with this extension.

J4Schema is integrated with JCE editor, so you need to install and use it as editor for your articles.