#435 – A couple of questions

Posted in ‘J4Schema’
This is a public ticket. Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.
Wednesday, 21 January 2015 11:59 CET
belenm
 Hello, i have just purchased a susbcription to be able to use your J4Schema Pro extension. I have installed it without any problem and it seems to work. I've been reading carefully the documentation but i have a few doubts. I have a Joomla installation with Virtuemart. My Joomla and Virtuemart templates are heavily customised, i've got a lot of overrides. How can i install the modifications in your overrides without breaking my template's layout? I see it can be done automatically from the backend but this will damage mine. Also, once the overrides are properly installed, do the default published tokens in the component's backend work automatically?

Kind regards.
Custom Fields
Joomla! Version
2.5
Extension version (x.y.z)
5.3.0
Wednesday, 21 January 2015 12:06 CET
tampe125
Hello Belen,

if you have heavily customized templates you have to inject the tokens manually in your templates.
We can only provide an "enhanced" version of default Virtuemart templates.
You can use our work to identify the sections that needs J4Schema tokens: our component will search for them and then replace them with the correct Schema.org microdata.
signature.png
Thursday, 22 January 2015 12:45 CET
belenm
Thank you so much, i think i understand now how it works. One more question though, how can i add tokens to my VM's product images?

Regards
Thursday, 22 January 2015 14:02 CET
tampe125
You have to add the correct token (VM_MAIN_IMAGE if I remember correctly) as attribute of the img tag.
signature.png
Friday, 23 January 2015 10:59 CET
belenm
Thanks! Can VM's custom filters have tokens too?
Monday, 26 January 2015 06:43 CET
tampe125
Yes, they can, however you have to create such tokens (if they don't exist) and apply them manually
signature.png
Tuesday, 27 January 2015 08:53 CET
belenm
Ok, thanks! : )
Tuesday, 27 January 2015 11:24 CET
belenm
One more thing, when i try the VM image token i get this error off Google's testing tool

Item
type: https://schema.org/product
property:
image: http://www.mywebsite.com/images/stories/virtuemart/product/ron_miel.gif
Error: Missing required field "name (fn)".

Tuesday, 27 January 2015 17:53 CET
tampe125
You have to specify the name for the product: you have to wrap the Product name with a span element (if it's not present) and add the VM_PRODUCT_NAME token
signature.png
Wednesday, 28 January 2015 09:41 CET
belenm
Ok, got it, thank you so much for all the help : )
Wednesday, 28 January 2015 12:38 CET
tampe125
You're welcome!
signature.png
This ticket is closed, therefore read-only. You can no longer reply to it. If you need to provide more information, please open a new ticket and mention this ticket's number.

SUPPORT IS PROVIDED IN ENGLISH OR ITALIAN ONLY.
Please make sure that your question is not answered in the documentation before submitting a ticket.
It will save you time!

SUPPORT IS PROVIDED TO SUBSCRIBERS ONLY.
You can review all public tickets, but if you want to open a new ticket you must have a valid subscription.
You can purchase it here