#323 – Error Using Tracktime

Posted in ‘TrackTime’
This is a public ticket. Everybody will be able to see its contents. Do not include usernames, passwords or any other sensitive information.
Wednesday, 16 July 2014 05:02 CEST
 I am developing a Joomla 2.5 website for a non-profit and have encountered an issue with using the Tracktime extension. I was able to download and install it with no issues. It does appear as an item under Components. However, when I try to assign it to a menu, it does not appear as a selection in the dropdown. In addition, it gives me three errors, all the same (see attachment):

Error loading component: com_pftime, 1
Error loading component: com_pftime, 1
Error loading component: com_pftime, 1

Please advise as soon as possible as I need to move quickly on this website. If I can get the free version to work, perhaps I may purchase the Pro version.
Custom Fields
Joomla! Version 2.5
Extension version (x.y.z) 3.0.2
 
margaret
Wednesday, 16 July 2014 14:36 CEST
Hello Margaret,

we are not the developers of com_pftime, you should ask support to them.
signature.png
tampe125
Thursday, 17 July 2014 06:26 CEST
Davide,
You are correct, the error messages relating to com_pftime were a leftover from a previously installed extension.

Thus, I deleted the menu item and re-added one to ensure that there were no carry-over issues.

In doing so, I still have the issue I outlined above. I was able to download and install it with no issues. It does appear as an item under Components. However, when I try to assign it to a menu, it does not appear as a selection in the dropdown.

I have attached a copy of the selections in the menu dropdown to prove that indeed Tracktime is not there as a selection option.

Please advise as soon as possible as I need to move quickly on this website. If I can get the free version to work, perhaps I may purchase the Pro version.
 
margaret
Thursday, 17 July 2014 06:29 CEST
Here is the attachment I refer to above.
 
margaret
Thursday, 17 July 2014 10:41 CEST
I think you hit a very nasty bug inside Joomla.
Sometimes, if a component fails to create the menu entry, your menu table gets corrupted: Joomla will create the new entry outside the main tree (so you won't be able to select it) or, even worse, it will create it in the right place, put it is unpublished by default and the user has no way to enabled it (!!!).

Sadly these are Joomla bugs, they were reported long time ago, but they said that we have to wait for a proper fix...
Time is passing but no fix has been published, however we are working for a workaround that will be released in the next version.

In the meantime, I'd suggest you to try to reinstall TrackTime (without uninstalling it), if the menu is still missing, please try to uninstall and reinstall again.
I'm sorry for the trouble, but as you can understand, that's something not related to our software.
signature.png
tampe125
Thursday, 04 September 2014 00:45 CEST
This ticket has been automatically closed. All tickets which have been inactive for a long time are automatically closed. If you believe that this ticket was closed in error, please contact us.
system
This ticket is closed, therefore read-only. You can no longer reply to it. If you need to provide more information, please open a new ticket and mention this ticket's number.

SUPPORT IS PROVIDED IN ENGLISH OR ITALIAN ONLY.
Please make sure that your question is not answered in the documentation before submitting a ticket.
It will save you time!

SUPPORT IS PROVIDED TO SUBSCRIBERS ONLY.
You can review all public tickets, but if you want to open a new ticket you must have a valid subscription.
You can purchase it here